Installation on WIndows Cygwin

+1 vote
asked Apr 25 by kim.hwanmun (130 points)

Hi, I am trying to install itensor on my Windows laptop with Cygwin. While it is working well with Mac machine, Windows installation keep showing following error:

make[1]: Entering directory '/ITENSOR/itensor'
Compiling itensor/util/args.cc with optimizations
util/args.cc:8:31: fatal error: itensor/util/args.h: No such file or directory
compilation terminated.
Failure while executing command: g++ -m64 -std=c++11 -c -I/ITENSOR -I/openblas/include -fpermissive -DHAVELAPACKCONFIGH -DLAPACKCOMPLEXSTRUCTURE -O2 -DNDEBUG -Wall -DPLATFORMopenblas -DASSERTMACROSDEFINEVERSIONSWITHOUTUNDERSCORES=0 -DPLATFORMopenblas -DASSERTMACROSDEFINEVERSIONSWITHOUT_UNDERSCORES=0 -o util/args.o util/args.cc
make[1]: *** [Makefile:57: util/args.o] Error 1
make[1]: Leaving directory '/ITENSOR/itensor'
make: *** [Makefile:14: itensor] Error 2

It seems the directory is not properly included with -I flag, but I cannot find why. I would greatly appreciate it if anybody can advise this.

Thank you!

commented Apr 25 by kim.hwanmun (130 points)
For information, it is WIndows 10 laptop and Cygwin is x86 64bit version, g++ installed(checked working with other codes).
commented Apr 26 by kim.hwanmun (130 points)
Problem solved:
It was just the issue of Cygwin. Cygwin seems not recognizing -nix type paths. So I had to set paths explicitly, e.g. PREFIX=C:/cygwin64/ITENSOR, and similarly for -I and -L paths for lapack and blas. Hope it helps other Windows users that are not familiar with Cygwin as myself..  :)

2 Answers

0 votes
answered May 7 by miles (15,200 points)

Glad to hear you solved your problem! (And sorry about the slow reply.) Hope you are finding the library useful and great that it's working now.

0 votes
answered Jun 10 by zhangqiz (200 points)

Would you please upload or copy your mk file here? That will help me a lot. I have problem of mk file, too.

commented Jun 10 by kim.hwanmun (130 points)
I did manually put commands instead of using mk file. However, it seems there were other problems after the installation.. I gave up using ITensor on Windows, and I am currently using ITensor in Linux virtual machine instead.
Welcome to ITensor Support Q&A, where you can ask questions and receive answers from other members of the community.

Formatting Tips:
  • To format code, indent by four spaces
  • To format inline LaTeX, surround it by @@ on both sides
  • To format LaTeX on its own line, surround it by $$ above and below
  • For LaTeX, it may be necessary to backslash-escape underscore characters to obtain proper formatting. So for example writing \sum\_i to represent a sum over i.
If you cannot register due to firewall issues (e.g. you cannot see the capcha box) please email Miles Stoudenmire to ask for an account.

To report ITensor bugs, please use the issue tracker.
...